Диапазон ячеек Excel

Обычно диапазоном ячеек называется прямоугольный блок соседних ячеек. Это, так называемый, смежный диапазон. Есть еще несмежные диапазоны, состоящие из нескольких смежных. На мой взгляд, термины не совсем удачные. Лучше подошли бы названия «простой» и «составной».

Смежные (простые) диапазоны Excel

Для простоты будем называть их просто диапазонами. Они могут состоять из

  • Одной или нескольких ячеек Excel
  • Одной или нескольких строк
  • Одного или нескольких столбцов
  • Всех ячеек листа Excel

Как задаются диапазоны

Диапазоны из одной или нескольких ячеек задаются адресами своих угловых ячеек — левой верхней и правой нижней ячеек, разделенных двоеточием.

Адрес Диапазона

Адрес диапазона, показанного на рисунке

B3:F8

На листе Excel диапазон можно выделить с помощью мыши. Надо щелкнуть левую верхнюю ячейку и, удерживая клавишу Shift, щелкнуть правую нижнюю ячейку диапазона.

Можно ввести адрес в Поле адреса и нажать Enter, будет выделен указанный диапазон.

Адрес диапазона в поле адреса

После нажатия клавиши Enter

Выделенный диапазон

Задание в формуле:

Адрес диапазона в формуле

Диапазоны, состоящие из одной или нескольких строк задаются номерами первой и последней строк, разделенных двоеточием. Например:

2:3  — Строки 2 и 3

На листе Excel их можно выделить с помощью мыши. Щелкнуть в левой части окна Excel номер первой строки диапазона и, удерживая клавишу Shift, щелкнуть номер последней строки.

Можно ввести адрес (номера первой и последней строк, разделенные двоеточием) в Поле адреса и нажать Enter.

Диапазоны, состоящие из одного или нескольких столбцов задаются буквами первого и последнего столбцов, разделенных двоеточием. Например:

C:D  — Столбцы C и D

На листе Excel их можно выделить с помощью мыши. Щелкнуть в верхней части окна Excel букву первого столбца диапазона и, удерживая клавишу Shift, щелкнуть букву последнего столбца.

Можно ввести адрес в Поле адреса и нажать Enter, будет выделен указанный диапазон.

Диапазон, состоящий из всех ячеек листа Excel можно выделить, нажав Ctrl+A. Иногда выделяются не все ячейки, а некоторый блок, в этом случае надо еще раз нажать Ctrl+A. Другой способ — кликнуть мышью левый верхний угол таблицы выше первой строки и левее столбца A.

Несмежные (составные) диапазоны Excel

Состоят из нескольких смежных, они задаются перечислением составляющих их смежных диапазонов, разделенных точкой с запятой. Например:

A1:D3; C5:F8  — Два прямоугольных блока ячеек

2:3; C5:F8  — Строки 2,3 и прямоугольный блок ячеек

Допускается наложение составных частей

2:6; C5:F8  — Строки 2-6 и прямоугольный блок ячеек

Наложение диапазонов

На приведенном рисунке видно, что прямоугольный блок накладывается на строки.

С помощью мыши несмежный диапазон можно задать последовательно выделяя смежные диапазоны при нажатой клавише Ctrl.

Второй способ. Нажать Shift+F8. После этого можно последовательно выделять смежные диапазоны. Чтобы выйти из этого режима надо нажать Esc.

Сходство и различие диапазонов

Использование в формулах Excel

Смежные и несмежные диапазоны можно использовать в формулах.

Объединение ячеек

К смежному диапазону всегда можно применить операцию объединить ячейки. Даже в том случае, когда он состоит из нескольких строк или столбцов. Объединенная ячейка получает адрес и содержимое первой ячейки исходного диапазона.

К несмежному диапазону можно применить операцию объединить ячейки, только в том случае если он не содержит накладывающихся диапазонов. При этом на месте каждого смежного диапазона создается отдельная объединенная ячейка.

Копирование и перетаскивание

Смежный диапазон можно копировать и перетаскивать мышью.

Несмежный диапазон нельзя копировать, если он состоит из нескольких фрагментов. То есть, если он не представляет из себя прямоугольный блок соседних ячеек.

Несмежный диапазон нельзя перетаскивать мышью.

Операция пересечения в Excel

В Excel есть интересная операция, которая обозначается символом пробела. Это операция пересечения диапазонов. Можно делать пересечение двух и более диапазонов, но все они должны иметь общую область — прямоугольный блок ячеек, который и будет результатом пересечения.

При этом получается смежный (простой) диапазон, его можно копировать и перетаскивать мышью.

Пример 1: Пересечение строк 3 и 4 со столбцами C и D

3:4 C:D

=СУММ(3:4 C:D)

Пересечение диапазонов

Пересечение диапазонов и суммирование

Видим, что результат суммирования равен 4. Просуммировались только ячейки стоящие на пересечении строк 3, 4 и столбцов C, D.

Пример 2: Пересечение диапазона B3:D8 с диапазоном C6:F10.

B3:D8 C6:F10

=СУММ(B3:D8 C6:F10)

Пересечение диапазонов Блок

Пересечение диапазонов и суммирование Блок

Видим, что результат суммирования равен 6. Просуммировались только ячейки стоящие на пересечении блоков.

Посмотрите Excel таблицы
Фин.-эконом. расчетов
Инвестиции, Фин.анализ, Себестоимость,
Оценка бизнеса, Рентабельность продаж,
Платежный календарь